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LICENSES 
 

• For this tutorial: 
 
This work is licensed under the Creative Commons Attribution-Share Alike 3.0 Unported License. 
To view a copy of this license, visit http://creativecommons.org/licenses/by-sa/3.0 or send a letter to 
Creative Commons, 171 Second Street, Suite 300, San Francisco, California, 94105, USA. 
 

 
 
 

• For the OptFlux software: 
 
Copyright 2009 
IBB-CEB - Institute for Biotechnology and Bioengineering - Centre of Biological Engineering 
CCTC - Computer Science and Technology Center 
University of Minho 
 
This is free software: you can redistribute it and/or modify 
it under the terms of the GNU Public License as published by 
the Free Software Foundation, either version 3 of the License, or 
(at your option) any later version. 
 
This code is distributed in the hope that it will be useful, 
but WITHOUT ANY WARRANTY; without even the implied warranty of 
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 
See the GNU Public License for more details. 
 
You should receive a copy of the GNU Public License 
along with the code. If not, see http://www.gnu.org/licenses/ 
 
Created inside the SysBio Research Group (http://sysbio.di.uminho.pt) 
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FIRST THINGS FIRST! 
 
 
Hello and welcome to the OptFlux 2 beginner’s tutorial. If you haven’t already downloaded the software 
please do it here: www.OptFlux.org. 
 
After launching the software you’ll be presented with the layout depicted in the image below. Most of 
OptFlux main features and operations will be accessible to you either through the Menu or the Toolbar. 
You can also have access to them by right-clicking in the Clipboard area. Your data types i.e., the project, 
metabolic models, simulation/optimization results, etc., will always be placed in the Clipboard area. The 
Visualization Area is the place where you can examine those data types in greater detail. 
Click around to get familiar with it and after that jump to the next step. 
 

 

 
 

  

Clipboard Status Bar Visualization Area 

Menu Toolbar 



1ST
 STEP – CREATING A NEW PROJECT 
 
To follow the steps in this tutorial you need to download the file gomGG.zip, available in 
www.OptFlux.org/tutorial/gomGG.zip. The model therein contained is a simplified model for growth of 
Saccharomyces cerevisiae [Forster, J. and Gombert, A.K. and Nielsen, N. A functional genomics approach using 
metabolomics and in silico pathway analysis. Biotechnology and Bioengineering, 2002]. 
Extract the contents of that file to a directory of your choice.  
 
To begin the creation of a new project, you have to start the New Project Wizard. You can access it 
either through the File Menu or the Toolbar. 
 
 
 
 
 
 
 
 
 
 
You have the option to create the new project from two different sources: flat files and SBML file.  
  
 
 
 

1.1 – FROM FLAT FILES 
 
 

 
 
 

 
Step 1 

In the first step, the user must input 
a valid project name 
In the picture the name selected 
was “New Project” 
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In the second step, the user must 
select three files, which were 
provided along with this tutorial: 

Step 2 

• The first contains the 
reactions names and their flux limits 
– select gomper.fluxes

• The second contains the 
stoichiometric matrix – select 

; 

gomper.matrix
• The third contains the 

metabolite names (optional) – select 

; 

 
 

gomper.compounds 

In step 3, the first option concerns 
the indexing used in the 
stoichiometric matrix if the SPARSE 
option was selected. The user must 
select indexing starting at zero. For 
the remaining files, the user should 
select the comma separator for the 
Fluxes File and the tab separator for 
the matrix and metabolites file. 

Step 3 

 
 
 

 

In the fourth step, OptFlux 
automatically tries to find the 
biomass growth associated flux, 
since this information is essential 
for both simulation and 
optimization procedures.  

Step 4 

A heuristic method will 
automatically identify the reaction 
“BIOMASSX”.  
 
 
 
 



1.2 – FROM A SBML FILE 
 

 

In the first step, the user must input 
a valid project name. 

Step 1 

In the picture the name selected 
was “New Project” 
The user must select the SBML 
option in the bottom as the model 
source. 
 
 
 
 
 

 
Step 2 

In the second step the user must 
select the file to load and the type 
of SBML therein contained. In this 
example, the user must select the 
file gomGG.xml

 
 
 
 

 provided in the 
attached zip file. The type of file to 
select can be Standard SBML or 
CellDesigner SBML (this example 
contains CD annotations for 
visualization). 

The third step is relative to the 
extra-cellular environment. OptFlux  
will automatically try to find the 
extra-cellular compartment and 
the respective metabolites, using 
the compartments heuristics it will 
detects external metabolites based 
on the definitions of the 
compartments contained in the 
SBML file. 

Step 3 



 
 
 

In the fourth step, OptFlux 
automatically tries to find the 
biomass growth associated flux, since 
this information is essential for both 
simulation and optimization 
procedures.  

Step 4 

A heuristic method will automatically 

identify the reaction “BIOMASSX”. 

 

 

1.3 – PROJECT CREATED IN THE CLIPBOARD 
 
 
After following either step 1.1 or step 1.2, the user will now be presented with the scenario 
depicted in the following screenshot: 
 
 
 
In the image, one can see the default 
structure of any OptFlux project. The 
central data type is named “Original 
Metabolic Model”. Inside, one can 
access the flux limits information, 
metabolites information and also the 
stoichiometric coefficients in a human-
readable fashion. 
 
At this point the user should click 
around a bit to get familiar with this 
structure and the information therein 
contained. 

 
 
 
 
 
 
 



The viewers for the Reactions, Metabolites and the Stoichiometric Matrix are depicted in the 
screenshots below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  



2ST
 STEP – PERFORMING SIMULATIONS 
 
 

OptFlux allows the user to perform a simulation of the "wild-type" strain, i.e. of the model with no 
genetic modifications. 
Access the "Wild Type" option either through the "Simulation" menu or right clicking on the model 
icon in the clipboard.  

 

2.1 – PERFORMING A WILD-TYPE SIMULATION 
 

 
 

 
Step 1 

In the first step, the user must select the Project 
and the Metabolic Model to which the 
simulation will refer.  
 
This step is necessary since OptFlux supports 
multiple-projects and each project can contain 
an Original Metabolic Model and a Simplified 
Metabolic Model. 
 
In the context of this tutorial, leaving the default 
selection is just fine. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 

 
Step 2 

After completing all the previous steps, a new object named “Wild Type” is placed within the 

Simulation Results list. By left-clicking this object the user has access to detailed information 
about the performed simulation. The user can, for instance, see the values for all the fluxes the 

simulation method calculated and can even export the list of values to a text file.  



2.2 – PERFORMING A MUTANT SIMULATION – REACTION DELETIONS 
 

 
 
 
 
 
 
 
 
  
 
 

Step 1 
 
You can access the "Reaction Mutant" option under the "Simulation -> Mutants Simulation" 
menu or right clicking on the Metabolic Model icon on the clipboard.  

Step 2 
 
1. Reaction knockout list 
Selecting in the Reaction list you can 
add/remove (using the arrows buttons) 
reactions to the knockout list (the list of 
reactions to be deleted, on the right). 
 
2. Select Simulation Method 
OptFlux can use several simulation methods 
for knockout simulations, namely: 
Flux-Balance Analysis, ROOM-LP, ROOM-
MILP, MOMA 
 
ROOM-LP stands for the Regulatory On-Off 
Minimization Method (ROOM), using a 
linear programming (LP) relaxation; ROOM-
MILP is the original ROOM that uses a 
Mixed Integer LP (MILP) method; MOMA 
stands for the Minimization of Metabolic 
Adjustment method that uses quadratic 
programming. 
 
3. Objective Function Configuration 
Here you can select the reaction to optimize 
(biomass, by default), and you can also 
define if you will be maximizing or 



minimizing the flux. 
 
4. Select Environmental Conditions 
If you have created environmental conditions you can select them to be used as constrains in the 
simulation. These can be used to define the values of drain fluxes, i.e. the rates at which 
metabolites are consumed or produced. 
 
 
Step 3 

 And that's all!! You can press OK and the results will be loaded into the clipboard.. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.3 – PERFORMING A MUTANT SIMULATION – GENE KNOCKOUT 
 

Step 1 
 
You can access the "Gene Mutant" option under the "Simulation -> Mutants Simulation" menu 
or right clicking on the Metabolic Model icon on the clipboard.  



 
 
 
 
 
 
 
Step 2 
 
In the Gene Mutant Simulation you can select the model/project to work, and set up your 
configuration. 
 
1. Gene knockout list 

Selecting in the Gene list you can 
add/remove (using the arrows 

buttons) genes to the knockout list 
(the list of genes to be knocked out, 

in the right). In the Inactive 
Reactions list you can see the 

reactions that will be turned off 
knocking out that set of genes.  

 
2. Select Simulation Method 
OptFlux can use several simulation 

methods for knockout simulations, 
namely: 

Flux-Balance Analysis, ROOM-LP, 
ROOM-MILP, MOMA 

 
ROOM-LP stands for the Regulatory 

On-Off Minimization Method 
(ROOM), using a linear 

programming (LP) relaxation; ROOM-MILP is the original ROOM that uses a Mixed Integer LP 
(MILP) method; MOMA stands for the Minimization of Metabolic Adjustment method that uses 

quadratic programming.  
 
3. Objective Function Configuration 

Here you can select the reaction to optimize (biomass, by default), and you can also define if 
you will be maximizing or minimizing that flux. 

 



4. Select Environmental Conditions 
If you have created environmental conditions you can select them to be used as constraints in 

the simulation. These can be used to define the values of drain fluxes, i.e. the rates at which 
metabolites are consumed or produced.  

 

Step 3 

 And that's all !! You can press OK and the results will be loaded into the clipboard.. 
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3ST
 STEP – PERFORMING  OPTIMIZATION  

 
 

3.1 – OPTIMIZE THE KNOCKOUT SET - REACTION DELECTIONS 
 

Step 1 
 
You can access the "Reaction Knockout Optimization" option under the "Optimization" menu.  
 

 
 
 
 
 
 
 

 
 
Step 2 
You can select the model/project to work, and set up your optimization configuration.  
 
1.Select Project and Model 
In the Project combo box select the project where you want to perform the optimization, 
in the Model combo box select the model within the project that you want to use (if you 
have performed model simplification, the simplified models will be easier to handle by 
the optimization algorithms). 
 
2.Select Simulation Method 
OptFlux can use several simulation methods, namely Flux-Balance Analysis, ROOM-LP, 
ROOM-MILP, MOMA. Check  the Simulation How To's to find out more about these 
methods... 
 
3.Select Environmental Conditions 
If you have created environmental conditions you can select them to be used as 
constraints in the simulation. 
 
4.Select Objective Function 
OptFlux can use two types of objective function: 
BPCY - Biomass-Product Coupled Yield, YIELD - Product Yield with Minimum Biomass. 
The first calculates the product of the biomass flux and the compound production flux; 
the second, returns the value of the target compound production flux divided by the 
substrate consumption flux, if the biomass is larger than a minimum value, defined by the 
user.  

http://darwin.di.uminho.pt/optflux/index.php/Reaction_delection�
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5.Objective Function Configuration 
Here you can select the flux to be optimize (the compound you wish to produce), the flux 
that represents the biomass and the substrate that is in use.  
 

 
6.Select Optimization Algorithm 
OptFlux allows you to perform optimizations using one of the following algorithms: 
Cellular Genetic Algorithm, Evolutionary Algorithm, Simulated Annealing.  
 
7.Optimization Basic Setup 
Here you can configure the maximum number of solution evaluations (Simulations) and 
check the expected time to perform that number of evaluations.br> You can also set up 
the maximum number of knockouts and if the set of knockouts should be static or have a 
variable size.  
 
8.Essential information 
You can define if it is possible to knockout some special type of reactions like drains, 
transport and critical reactions (if you have loaded/created this information).  
 
 
 
 
 



Step 3 
 
And that's all, now you can press OK and check the results in the clipboard.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.2 – OPTIMIZE THE KNOCKOUT SET – GENE KNOCKOUTS 
 

Step 1 
 
You can access the "Gene Knockout Optimization" option under the "Optimization" menu. 
To use this optimization you have to use with a model with GPR (gene-protein-
reaction) information. 
 
 

 
 

 
 
 
 
 
Step 2 
You can select the model/project to work, and set up your optimization configuration.  
 
 
 



1.Select Project and Model 
In the Project combo box select the project where you want to perform the optimization, in the 
Model combo box select the model in the project that you want to use (if you have performed 
model simplification, the simplified models will be easier to handle by the optimization 
algorithms). 
 

 
 
2.Select Simulation Method 
OptFlux can use several simulation methods, namely Flux-Balance Analysis, ROOM-LP, ROOM-
MILP, MOMA.  
Check the Simulation How To's to find out more about these methods...  
 
3.Select Environmental Conditions 
If you have created environmental conditions you can select them to be used as constraints in the 
simulationIf you have loaded/created environmental conditions you can select them to use as 
constraints in the simulation.  
4.Select Objective Function 
OptFlux can use two types of objective function: 
BPCY - Biomass-Product Coupled Yield, YIELD - Product Yield with Minimum Biomass.  
The first calculates the product of the biomass flux and the compound production flux; the 
second, returns the value of the target compound production flux divided by the substrate 
consumption flux, if the biomass is larger than a minimum value, defined by the user 
5.Objective Function Configuration 
Here you can select the flux to be optimize (the compound you wish to produce), the flux that 

http://darwin.di.uminho.pt/optflux/index.php/Environmental_conditions�


represents the biomass and the substrate that is in use. 
 
6.Select Optimization Algorithm 
OptFlux allows you to perform optimizations using one of the following algorithms: 
Cellular Genetic Algorithm, Evolutionary Algorithm, Simulated Annealing 
 
7.Optimization Basic Setup 
Here you can configure the maximum number of solution evaluations (simulations) and check the 
expected time to perform that number of evaluations. 
You can also set up the maximum number of knockouts and if the set of knockouts should be 
static or have a variable size. 
 
8.Essential information 
If you loaded/created some essential genes you can define if it is possible to knockout some 
critical genes. 
 
Step 3 
 
And that's all, now you can press OK and check the results in the clipboard.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



4ST
 STEP – INTERACTION WITH CELLDESIGNER  

 
 

3.1 – LOADING A CELLDESIGNER MODEL FOR VISUALIZATION 
 

You can access the "Load CD model for visualization" option under the "Plugins -> Biovisualizer" 
menu. 

 
 
In the project combo box select the project where you want to load the CD into, then choose 
the file and write the name for the CD visualization object in the clipboard. 

 

3.2 – SIMULATION RESULT OVERLAP WITH CD MODEL 
 

You can access the "Create a Graph Overlap" option under the "Plugins -> Biovisualizer" 
menu. 

 
 
Select the Project to use, and the simulation result and model to use in the graph overlap. 

http://darwin.di.uminho.pt/optflux/index.php/Image:Biovisualizer_menu.png�
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Then you can visualize the generated graph overlap model, present in the Project 
Elements section of the clipboard. 
 

 

http://darwin.di.uminho.pt/optflux/index.php/Image:Graph_overlap.png�
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